Trading

macOS 10.12 Sierra: Will Adobe software work?

Now that macOS 10.12 Sierra is available from the Mac App Store, you’re probably wondering whether your Adobe software will work in the new Mac operating system.

With every Mac system upgrade, information about compatibility is often not available on the first day the new system is available, and emerges over time. If you use your Mac to run a business or as a serious hobby, do not upgrade to Sierra until you’re prepared to recover if things don’t work out. (That applies to any operating system upgrade on any device.) Wait until you are confident that all of your software and hardware is compatible, then back up everything, then upgrade. With that in mind, here’s what I know so far about the state of Adobe software in Sierra.

The next section is about the Creative Cloud versions. If you’re looking for information about older versions, jump to:

Adobe Creative Suite 3 through 6 (CS2–CS6)

Adobe Creative Suite 2 (CS2)

Official statements and verified reports

The short answer is that the latest updates are the most compatible with Sierra. In most cases that means the CC 2017 versions, which are now available. Install them using the Adobe Creative Cloud desktop application.

Adobe posted a general statement about application compatibility (macOS Sierra (10.12) compatibility FAQ | Creative Cloud), but for now it links to the Photoshop and Lightroom statements below. It also claims that other most Adobe applications do not require updates to be compatible, and that any problems can be reported using the Adobe bug reporting form.

This section is updated as new information becomes available.

Adobe Photoshop Lightroom

According to the system requirements for Adobe Photoshop Lightroom CC, it requires “macOS 10.12, 10.11, or 10.10” so it claims to be compatible with Sierra. This applies to the most recent version only, which at this time is Lightroom CC 2015.7/6.7 or later.

The Lightroom team posted a more specific Sierra statement (Lightroom and Sierra | macOS 10.12). It says “Adobe recommends that customers update Lightroom to the current version prior to updating macOS 10.12 (Sierra).” It lists a number of compatibility issues, especially with Lightroom 5 and earlier, saying:

To avoid these compatibility issues on macOS 10.12 (Sierra):

  • Update to Lightroom 2015.7/Lightroom 6.7, or
  • Remain on your current Mac OS X version and do NOT update to macOS 10.12 (Sierra) if you are running Lightroom 5 or earlier.

Earlier, “Lightroom Queen” Victoria Bampton published a blog post with similar findings about Adobe Photoshop Lightroom in Sierra (Lightroom and macOS Sierra Compatibility).

The Tone Curve may be difficult to control in Sierra. (Lightroom 6: Tone curve is Insensitive to MacBook Pro Touch Pad). Adobe said this was fixed in Lightroom 6.8 / CC 2015.8, but there are reports that variations on the problem still exist.

Adobe Photoshop CC

According to the system requirements for Adobe Photoshop CC 2017, it requires “macOS version 10.12 (Sierra), Mac OS X version 10.11 (El Capitan), or Mac OS X version 10.10 (Yosemite)” so it claims to be compatible with Sierra.

For Adobe Photoshop CC 2015, the Photoshop team posted a document (Photoshop and Sierra | macOS 10.12)  which they update with known issues. Most are minor, except that some users have encountered a crash when printing. ( Update:Adobe says the Sierra print crash is resolved for some users in macOS 10.12.1, and resolved for all users in Adobe Photoshop CC 2017.)

If you find a problem with Lightroom or Photoshop in Sierra, report it at the Photoshop Feedback site. If you run into a problem with other software such as Acrobat, Illustrator, InDesign, Premiere, or After Effects, try posting about it in the Adobe Forums.

Adobe InDesign CC

According to the system requirements for Adobe InDesign CC 2017, it requires “Mac OS X  10.10, 10.11 or 10.12” so it claims to be compatible with Sierra.

There is apparently an InDesign CC 2015 startup crash on Sierra when using a RAID with Adobe InDesign CC 2015 (11.4.1). The solution is to roll back to 11.4. The details are in an Adobe Forums post (InDesign crashes after start since Sierra update).

Adobe Illustrator

According to the system requirements for Adobe Illustrator CC 2017, it requires “Mac OS X versions 10.12 (Sierra), 10.11 (El Capitan), or 10.10 (Yosemite)” so it claims to be compatible with Sierra.

Adobe Premiere Pro CC

According to the system requirements for Adobe Premiere Pro CC 2017, it requires “Mac OS X  v10.10, v10.11 or v10.12” so it claims to be compatible with Sierra. If you’ve been having problems with Apple Metal GPU acceleration, some were resolved in the Premiere Pro CC 2017.0.2 (11.0.2) update.

There have been some long discussion threads about Premiere Pro issues in Sierra on the Adobe Premiere Pro user forum. Probably the biggest verified problem is an issue related to automatic graphics switching in Premiere Pro on the 2016 MacBook Pro, which runs only Sierra or later. That specific issue turned out to be a macOS bug, fixed by Apple as mentioned in their release notes for macOS Sierra 10.12.3. If you still experience GPU-related problems, Adobe is asking users to report them so that they can be fixed.

I haven’t seen an Adobe statement about Sierra compatibility for Premiere Pro CC 2015.

Adobe After Effects

According to the system requirements for

Adobe After Effects CC 2017, it requires “macOS X versions 10.10 (Yosemite), 10.11 (El Capitan), or 10.12 (Sierra)” so it claims to be compatible with Sierra.

Adobe Acrobat Pro DC

According to the system requirements for Adobe Acrobat Pro DC, it requires “Mac OS X v10.9, 10.10, 10.11, or 10.12” so it claims to be compatible with Sierra.

Adobe PDF

Many Mac users prefer to view PDF files in Apple Preview instead of Adobe Reader or Adobe Acrobat. However, in macOS Sierra, Apple rewrote the PDFKit framework and this rewrite is apparently very buggy. Apple has been fixing these bugs, but some remain in macOS Sierra 10.12. An article by Mac veteran Adam Angst at TidBITS ( Sierra PDF Problems Get Worse in 10.12.2 ) describes some of these bugs, which can result in data loss in some cases. In the article, developer Christian Grunenberg says makes a statement that has always been true to some extent, but even more so in Sierra:

Apple supports only a subset of the PDF specification, and that support has always been buggy.

For maximum compatibility and reliability with all PDF versions and features, you’ll want to work with PDF files in Adobe Reader or Adobe Acrobat Pro, or a third-party application that does not rely on Apple PDFKit.

Update:  Apparently the macOS 10.12.3 update fixes some, but not all, of the bugs mentioned in the TidBITS article.

Older versions of Adobe software (CS3–CS6)

I have upgraded my test Mac to the release version of Sierra. So far, various versions of Adobe Creative Suite (CS) applications I tried (the oldest being Photoshop CS3) are at least able to launch in the Sierra beta. As in El Capitan and earlier, older Adobe applications are able to launch after you run the Apple installer for Java for OS X 2015-001. If you see the alert below, clicking More Info takes you directly to the Apple download page for Java for OS X.

JavaScript requirement alert in macOS 10.12 Sierra.

Adobe software older than the Creative Cloud (CC) versions are not officially supported on macOS 10.12 Sierra. That doesn’t mean they won’t work; it just means that if those old versions have any new issues related to macOS 10.12 Sierra, there won’t be any updates to address them (that is, you’re on your own). After doing some quick tests, Adobe application compatibility with Sierra appears to be comparable to their compatibility with OS X 10.11 El Capitan, with very similar limitations and conditions to those we’ve seen with the past few OS X releases. If Adobe does what they’ve done in the past, they will not be testing most older (pre-Creative Cloud) software at a level that can confirm which specific features do and don’t work; you’ll have to do that testing yourself (see “How to test macOS 10.12 Sierra yourself” below).

Photoshop CS3 working in macOS 10.12 Sierra.

Photoshop CS3 and up will run in macOS 10.12 Sierra after Java is installed.

With that in mind, here are a few things I’ve seen since trying out some older versions in Sierra.

Be prepared to uninstall and reinstall if needed. Adobe applications were already installed when I upgraded my test Mac to Sierra. After the upgrade, some older Adobe applications had licensing errors. I was able to fix these by uninstalling and reinstalling those applications, and the lesson here is to always make sure you have all of the information you need (such as license keys or registration numbers) to reinstall any of your key software.

“Installer Failed to Initialize” error. Some Adobe installers may fail to launch with the error“We’ve encountered the following issue. Installer failed to initialize. This could be due to a missing file. Please download Adobe Support Advisor to detect the problem.”

Installer Failed to Initialize” error.

Unfortunately, Adobe Support Advisor no longer exists, but there is an immediate workaround that should get the installer going:

  1. Right-click (or Control-click) the installer and choose Show Package Contents.
  2. In the Install window that opens in the Finder, go to the Contents/MacOS folder, and in there, double-click Install. That will open the Terminal application, some lines of code will automatically run, and the actual Installer should successfully launch.

Make a note of this workaround, because any pre-CC installers are unlikely to be updated.

[Update: A few days after I posted this, Adobe published a help document that confirms this workaround: Installing Creative Suite on macOS 10.12 (Sierra)]

Adobe Illustrator CS4. When starting the application, you may see an “Error loading plugins” alert which mentions PhotoshopExport.aip and PhotoshopImport.aip. This has been a problem for several OS X versions, and there is no fix that I know of. You can only work around it by clicking “Don’t show again” in the alert.

Adobe Illustrator CS5. Illustrator CS5 may crash on quit; this problem also existed in El Capitan so try the solution offered at the Adobe forums (Illustrator CS5 crashing on exit), specifically the part about renaming /Library/Application Support/Adobe/CS5.5ServiceManager to

/Library/Application Support/Adobe/CS5.5ServiceManager.bak


Category: Advisor

Similar articles: